woshidan's loose leaf

ぼんやり勉強しています。

rbenvでrubyをバージョンアップする

rbenvでrubyをバージョンアップする場合の手順

# インストール可能なrubyのバージョンの一覧を調べる
$ rbenv install -l
# rbenvで新しいバージョンを管理できるようにする
$ brew update # 何らかのライブラリをアップデート, インストールする前にbrew自体を取得する
$ brew upgrade rbenv ruby-build
# 指定したバージョンをインストールする
$ rbenv install `target-version`
# そのディレクトリ以下で管理するバージョンを設定する
$ rbenv local `target-version`
# bundlerはrubyのバージョンごとに管理されているようでエラーがでる。bundlerを新規にインストールする。
$ gem update bundler
$ gem install bundler
# bundlerを使ってインストールする他のgemもrubyのバージョンごとにインストールされているようで
# 他のバージョンでinstallしていたgemもinstallがはじまった
$ bundle install